Boot fails after rooting Honor 7 PLK-L01 C185B370 (android 6.0)



  • unlocked phone and installed twrp-3.0.2-0-plank without issues.

    Tried to install SuperSU-v2.78-201609011115 via adb sideload and the twrp install thing, but everytime I end up with a phone failing to boot.

    if I push some old app_process and app_process64 through adb inside recovery, I can boot again, but the supersu won't work in this case.

    I doubt I do anything wrong, because with the C185B130 (5.0.2 based) version it worked, allthough I used a much older version of superSU, 2.4x something.

    Anybody any ideas?



  • I get working adb access though with the failed boot, I suspect that some services don't want to start and it just gets stuck, due to something. Couldn't find anything obviously wrong inside logcat though.



  • progress. managed to root my device with BETA-SuperSU-v2.71-20160331103524.zip and SYSTEMLESS=true in /cache/.supersu

    I guess supersu didn't detect that I was running 6.0 and used the system root method.