2.82 is also broken!



  • This is about SuperSu 2.82 that is currently on Google play. The developers know that 2.80 and 2.81 have problems but they seem to think these problems are solved in version 2.82. That is not the case.

    On my rooted nexus 5 running stock 5.1.1 with xposed the supersu 2.82 that is available for update on Google play causes the phone to "optimize" every installed app on every boot! This means every reboot takes almost 30 minutes which is inacceptable.

    I wrote a message here about this a week ago (which was was removed) and when I tried the update on Google play a few minutes ago nothing had changed.

    I understand that developers can need time to fix things, but the version currently on Google play should be removed until the problem is fixed instead of making users suffer unnecessarily.

    Thank you



  • I guess the developers can't be bothered to even reply. Forget about their fixing the problem.
    So sad. The destruction of a great app.


  • Samsung root

    To answer your questions:

    1. Roll back to your original SuperSU. Lolipop systems shouldn't go beyond 2.76. And it's always the rule that "if your SuperSU works, DO NOT attempt to update". I have stressed this many times in recent updates, but no one listens and they come here to vent their update problems.
    2. Try Magisk. If you wanna use Xposed, I would personally recommend magisk. Yes I know it's weird for a veteran SuperSU user to recommend Magisk. But in terms of compatibility, I admit magisk is more convenient integrating Xposed than SuperSU.
    3. There is NO developer here. Only amateurs like me. This place is for entry level problems. If you wanna make demands, go talk to CCMT or Chainfire personally.
      And if you have to ask, no I do not work for Chainfire nor CCMT. I just like to hang out here.

  • Samsung root

    With those "administrative matters" sorted out, I'm gonna say something because of your comments:

    1. Please stop acting like a king here. If you want people actually care about what you say, you need to take yourself seriously. And that means getting yourself a name instead of a "guest".

    2. Please stop being so ignorant trying to represent everyone. You have no idea why Chainfire released 2.82 and simply assumed it didn't work ONLY BECAUSE IT didn't work on your phone. In fact, it solved countless update failures from 2.80 & 2.81. Your own failure is not everyone's demise.

    3. I never delete negative comments, unless it is just pure rant, ads or toxic messages. If your "deleted" comments belong to this category and I deleted them, please follow the rules next time.



  • I apologize if my frustration showed. I did not mean any harm. Just trying to get advice from those responsible for the Supersu app.

    Here's how I got to this forum. I went to Google play, searched for the Supersu app and then clicked on what was listed as the app's website. That link took me here. So it was not unreasonable for me to assume this is the app's official website. There was no way for me to assume otherwise...... or to know where to go to reach the app's official website. I also sent an email to the email address listed on the same Google play supersu page. Don't know where it went and I never got any response.

    I have no desire to move away from version 2.79. I did not go looking for an update. It is Google play that tells me I need to update. (I would love to attach the screenshot but don't know how). So I once accidentally clicked on "update all" which is how supersu messed my phone up for over a week. There is no easy way for me to stop Google play from listing this as a recommended update. It took me weeks to figure out which app update was responsible.

    Finally, I am far from being the only one having problems with this update. In my search for a solution I came across many others having the identical boot problems and struggling to figure out which app was responsible.

    So again, I truly apologize if my message was inappropriate. I did not mean it that way and am sorry. Because this forum's main page has stickies indicating known problems with versions 2.80 and 2.81 and has version 2.82 at the top of the forum page in large it gave me the impression that the responsible people believed 2.82 was the solution. But I wanted to let someone know it too has boot problems. Maybe they can do something so it does not appear on Google Play as a recommended update.

    The moderators on this forum may perhaps know better than me how to contact the appropriate people of the problems I pointed out. Again, my sincere apologies if I did it the wrong way.


  • Samsung root

    You are right, it does feels like " I did everything right and still got the wrong s**t and screwed my phone". Not to mention the newly added (and then deleted) permissions in 2.80. A few weeks ago, I was equally pissed off and even went to XDA joining the protest. So there is really no need to apologize for being frustrated.
    Now I feel that this is probably what happens when an app is transferred. I personally think the new team donno how to operate SuperSU like what Chainfire did. They probably still have a long way to go. Yet I am still glad they didn't convert SuperSU into a "money making bloatware" like what usually happens. Lets hope this can last.
    P.S. Chainfire released the 2.82 SR1, flash it with TWRP should restore your phone and not to worry about Google Update.



  • @Akkash1105
    Thank you for understanding.



  • Nasıl root atarm vestel venüs v5


You may be interested in..

 

Looks like your connection to SuperSU Forum-where rooting fans gather was lost, please wait while we try to reconnect.