Please help, I've botched my root.



  • Hey, someone please help me out. I recently used a service to root my Samsung galaxy s7 edge. Everything seems to have worked out properly, they used supersu, Odin, flashfire, and maybe some other stuff...Okay, so here's where I messed up. I couldn't log back into my snap account once I had logged out. I did some amount of research and found out that Android phones that have been rooted get the same error message I received. Oh no! It looks like your log in temporarily failed... Anyway, I also found out that some people can hide the root from apps. I downloaded "Hide my root" from the app store, which I had watched an individual use to successfully log back into snap. I followed the simple directions, but the process of hiding the root never finished. I had to restart, and since then seemingly nothing really has root access anymore, and furthermore I still can't log back into Snapchat. I have uninstalled "Hide my root" but Supersu still says "SU binary occupied"... Now I don't know what to do. Root Checker still says I'm rooted, but like I said, everything stills seems to have lost root access. I really need some help here folks. Life is hard now.



Looks like your connection to SuperSU Forum-where rooting fans gather was lost, please wait while we try to reconnect.