SuperSU ONE-WAY with DEAD-END on 7.1.2 (pre-installed)



  • Hi Mods, Hi all!

    Thnx in advance for your help.

    My problem is absolutely the same, explained in this form, but not between 4.2 and 5.1. I´m a software dev also and I know how fast things can happen. But in this case I tried everything I found on the web and I could imagine as a technical versed person. No chance. 100% Show-Stopper.

    System: 7.1.2
    SuperSU: 2.79 (by SuperRoot, button PhoneInfo)
    SuperSU: 2.78 (by Settings Tab in pre-installed SuperSU app, located in /system/app/Superuser/Superuser.apk)
    Device: Netxeon Orbsmart S84 (Amlogic s912, T820)

    I have stock firmware and - by now - I´m not willing to flash cwm or twrp. I purchased this device two weeks ago, so I don´t want to lose warranty conditions.

    This device was delivered with pre-installed SuperSU app v. 2.79 (or 2.78???). It was reasonably naive to believe, that only very few users got this problem, because everyone who gets this device will have it to.

    As I boot the device, everything seems to be fine. But than I install ES File Explorer. I go to settings there and activate root explorer. I get the message, that ES File Explorer got root access for this session (not literal, but similar; I granted generally!).

    But I´m not at all able, to open the context menu for root explorer (grant r/w to...). Just nothing happens. No error, no effect, nothing. Just silence. And - if I try to add a folder e.g. to system, it fails as of no permission problem.
    So, the main problem is that SuperSU was pre-installed by factory default, it seems to work as expected (configurable, grant/edit/delete su to apps, etc.) but the su access is not available in any case, like it never has been installed.

    When I opened up SuperSU app, I immediately got the alert, to update the su binary and - if I do not - that SuperSU will probably not work as expected. So I did. Than - not tapping on "Reboot" but on "Ok" - SuperSU really works as expected! I´m able to do everything, I want to do.
    But some time I have to reboot the device and when I do that: "Bootloop 1".

    Flash back to recovery.

    Then I thought, (because I purchased SuperSU Pro loooooong time ago) I´d try to update SuperSU and afterward install the Pro-Activation-App. "Bootloop 2".

    Again flash back to recovery.

    No I tried to only update pre-installed SuperSU app to the actual version in Play Store (2.82). "Bootloop 3".

    Flash back to recovery.

    I tried everything I could imagine. No success at all.

    Please give me some hints to the right direction. But not that one, to flash CWM or TWRP (etc.) and.... As I said: I don´t want to lose my warranty conditions and also, I don´t want to wait until this warranty conditions are gone, to risk something. As a matter of fact, this device was not the most expensive, but a hundred bugs are a hundred bugs. And of course I don´t want to jump around by trial and error from device to device to device...

    I would be so happy to get some help from you.

    Best regards, Ingmar


 

Looks like your connection to SuperSU Forum-where rooting fans gather was lost, please wait while we try to reconnect.