Rooting - Huawei g play mini (CHC-U01) - Android 6 Marshmallow



  • Hi Guys,

    I am trying to root a Huawei g play mini (CHC-U01) with Android 6 Marshmallow installed.
    The bootloader is unlocked and TWRP is installed.

    When I try to install the current SuperSU zip file (Version 2.79) with TWRP the installation runs without any errors.
    When I boot the Android System afterwards, it gets trapped in a boot loop.

    Is there a way to debug/log the booting process?

    Sadly there are only a little number of posts regarding this smartphone on the internet.
    I really hope you can help me.

    Thanks in advance,
    Ronny

    Installation Log:
    SuperSU installer

    • Mounting /system, /data and rootfs
    • Extracting files
    • Detecting System compatibility
    • System mode
    • Disabling OTA survival
    • Removing old files
    • Creating space
    • Placing files
    • Restoring Files
    • Post-installation script
    • Unsmounting /system, /data
    • Done !
      Updating partition
      ...done


  • Hi again,

    maybe I get a reply if the question is less specific.
    Is it possible that an old Version of SuperSU does the Trick?
    Or is newer always better?
    Does it make sense to search for rooting instructions for Smartphones wit the same OS Version?

    Looking forward to your reply.

    Regards, Ronny



  • Hi Guys,

    It finally worked!

    My Huawei g play mini CHC-U01 with Android 6 Marshmallow is rooted!

    It worked with this version of superSu:
    https://download.chainfire.eu/1021/SuperSU/SR3-SuperSU-v2.79-SR3-20170114223742.zip

    Thank you ChainFire!

    Find more information about the entire process (besides the super su version) here:
    https://forum.xda-developers.com/honor-4c/how-to/root-honor-4c-root-recovery-bootloader-t3318406

    I am closing this thread now.
    Huawei g play mini CHC-U01 with Android 6 Marshmallow rooting solved.



  • ~~

    • [strikethrough text](link url)~~


Looks like your connection to SuperSU forum-where rooting fans gather was lost, please wait while we try to reconnect.