Failed to root XT1581 and stuck on Moto logo.



  • Model: XT1581 (dual SIM, same as MXF version)
    ROM: XT1580_KINZIE_RETMX_DS_6.0_MPK24.78-8_cid12_subsidy-DEFAULT_CFC.xml

    version-bootloader: moto-msm8994-A8.52
    cid: 0x000B
    unlocked: yes
    securestate: unlocked
    ro.build.fingerprint[0]: motorola/kinzie_retmx_ds/kinzie_ud
    ro.build.fingerprint[1]: s:6.0/MPK24.78-8/8:user/release-ke
    ro.build.version.full[0]: Blur_Version.24.11.8.kinzie_retmx

    And here's what I did:

    1. Unlocked the bootloader and flashed the 6.0 ROM without error.
    2. Boot into the system without error.
    3. Flashed TWRP (3.0.0) and boot in recovery with out error.
    4. Installed SuperSU 2.79 without error. Also tried 2.78-SR1.
    5. Reboot to system and stuck on Moto logo. The only thing I could do to fix it is reflash the firmware again.

    I thought it may caused by ForceEncrypt which is introduced in Android 6.0. I've tried [Format Data] in TWRP and got the following result:

    Done.
    Failed to unmount '/data' (Device or resource busy)
    You may need to reboot recovery to be able to use /data again.
    

    I don't know if the encryption has been removed successfully but I still get stuck at Moto logo.

    I also tried systemless side load SuperSU but didn't help.

    So did I do something wrong?







  • @Samsungaccount

    Problem solved.

    1. Flash in stock 6.0 firmware;
    2. boot into fastboot mode and load TWRP (3.0.2) with /system READ ONLY mode. I think this is the cause for the failure;
    3. Install SuperSU (2.7.9-SR3). And saw a message "System-less mode. Boot image support required." on terminal. What does "boot image support reqiured" means?
    4. Reboot and SuperSU works like a charm.

    Update: I've tried to boot TWRP without /system write protection and flash in SuperSU 2.79-SR3 successfully. So only the SuperSU is responsible for this issue?


Log in to reply